Kubotek Forum

KeyCreator & KeyCreator Viewer Technical discussion of CAD/CAM and integrated partner products
Kubotek Forum > KeyCreator & KeyCreator Viewer > WeIrD PrInTiNg AnOmAlY View modes: 
User avatar
Advanced member
Advanced member
kspangler@midwestfab.com - 10/21/2020 2:37:19 PM
   
WeIrD PrInTiNg AnOmAlY
So I run into some oddities on occasion but today one of my users brought something to me that has left me baffled. As you can see in the attachments he is trying to print an instance in color but for some reason it is removing some of the solids. The first image is what we actually see from Layout Mode and the second is the Print Preview of it. It looks the same when actually printed.
I have repaired solids and fixed solid normals and resized solids to insure there was no strange interference causing it plus a few other things including rebuilding the main solid all to no avail.
One thing I do notice though is that when I click print preview I can briefly see the image being re-rendered and during that process it appears that the solids in question get rendered in/under the main block as you see in the Print Preview, as if during the print process it doesn't know where that solid actually is in 3d space. I tried moving the solid around in Model Mode as well in case there was some weird issue but nothing has worked. Incidentally, if we print the same image from Model Mode or if we Export as a color PDF in Instance Mode this prints correctly. 🙄


Dell Precision Tower 3620
Intel Core i7-7700 @3.60(x2)
16 GB of RAM
Nvidia Quadro M4000 (8GB)
Win 10 Pro 64Bit
KeyCreator 2020 SP1 (5897) V17.1.0
Seagate Barracuda 500GB 7200 Rpm HDD
3D Connexion SpaceMouse Enterprise
Logitech Performance MX Mouse

User avatar
Valued member
Valued member
francis.marcoux@ipexna.com - 10/22/2020 9:48:00 AM
   
RE:WeIrD PrInTiNg AnOmAlY
Something is wrong with the display... What if you change the display driver type? Does it help? If so, would any recent updates would be in cause?
What if you STEP export and re-import, does it fix the problem?
Francis Marcoux
IPEX Technologies
Latest KC version

User avatar
Advanced member
Advanced member
kspangler@midwestfab.com - 10/22/2020 9:56:19 AM
   
RE:WeIrD PrInTiNg AnOmAlY
Would the display affect the printed results though? We are getting these results after printing.

Dell Precision Tower 3620
Intel Core i7-7700 @3.60(x2)
16 GB of RAM
Nvidia Quadro M4000 (8GB)
Win 10 Pro 64Bit
KeyCreator 2020 SP1 (5897) V17.1.0
Seagate Barracuda 500GB 7200 Rpm HDD
3D Connexion SpaceMouse Enterprise
Logitech Performance MX Mouse

User avatar
Advanced member
Advanced member
michael@gutmandesign.com - 10/22/2020 11:01:42 AM
   
RE:WeIrD PrInTiNg AnOmAlY
Hi Keith,

I am pretty sure that this is a bug that persists through several releases.

For me, all kinds of rendered solids print incorrectly from layout.  PDF consistantly works however.

Guess it needs to be entered onto the new reporting system...

All the best,

Mike


User avatar
Advanced member
Advanced member
kspangler@midwestfab.com - 1/14/2021 2:12:34 PM
   
RE:WeIrD PrInTiNg AnOmAlY
Just wondering how this is coming along. Here is my most recent example.

What I'm expecting: