Kubotek Forum

KeyCreator CAD & CKD Viewer Technical discussion of CAD/CAM and integrated partner products
Customer Forum > KeyCreator CAD & CKD Viewer > Entities not X Forming to C Plane View modes: 
User avatar
Advanced member
Advanced member
timothyweastman@gmail.com - 6/15/2022 10:55:23 AM
Entities not X Forming to C Plane
I have a model in which entities do not X Form to the current C Plane. i.e. C Plane = 5, Display = 5 but when X Forming entities they do not move according to C Plane. Probably a simple brain fart but any suggestions would be welcomed. Don't think I've seen this before.

User avatar
Site admin
Site admin
Chris - 6/15/2022 5:11:48 PM
RE:Entities not X Forming to C Plane

If you would like to submit a support ticket and attach the file I would be happy to take a look.


Christopher Boivin
Technical Support Manager
Kubotek USA, Inc.
2 Mount Royal Ave, Suite 500 | Marlborough, MA 01752
Skype: christopher.boivin1
Phone: 800-372-3872 option 2
Fax: 508-229-2121

User avatar
Advanced member
Advanced member
michael@gutmandesign.com - 6/15/2022 7:51:33 PM
RE:Entities not X Forming to C Plane
Hi Tim,

Certainly take up Chris on his offer.  

But first if the transform dialog box asks for movements as dX, dY, & dZ then you are in WLD (world cp - see bottom bar on KC window). 

In that case the C Plane does not control the axis of the movements.  See the axis indicator in the lower left hand screen for the  direction of movements.

If the dialog box is showing dXC, dYC,& dZC the you are in CPL (construction plane mode - see bottom bar again) and the axis of movements will follow the upper right icon.

Double click on the CPL or WLD to toggle modes.

If you are extruding wireframe entities into a solid then the CP is ignored and the geometry is extruded normal to the plane of the wireframe entities.  

To change that behavior then check the "by vector" in the middle of the dialog box.  Make a line in the direction you wish to extrude and use that as the direction vector.