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CHAPTER 1 - Advanced Features.......................Pages 4-36
In this first section you will learn how to utilize some of KeyCreator’s more advanced 3D modeling features, such as:
	 Dynamic Transform
	 Topology Imprint
	 Prune
	 Graft
	 Unite
	 Subtract
	 Patterns
	 Hole Feature
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Advanced Features
Let’s start by building a basic hinge model.

The status bar on the bottom right of the screen should indicate this as shown.

If not, you can set the units as follows:
Go to File>Properties>Units/Tolerances and set as shown:
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Keep in mind as you proceed that you can utilize the Modeling and 
Advanced Modeling Palettes to create and modify geometry.

Set the view to Isometric (View 7) by selecting Alt+7 on your keyboard 
or by selecting the double arrow beside the Disp View icon           and 
choosing ‘7: Isometric View’ as shown:

Now set the construction plane (CPlane) to 1 by selecting Ctrl+1 on your 
keyboard or double arrows          of CPlane icon and choosing ‘1: Top 
CPlane’ as shown.
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Let’s begin!Let’s begin!
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Select Create>Primitive Solid>Block. Select the ‘Sketch’ option:

Select a point for the first corner, another point for a second corner, then select a third and final point to place the block. You should see a dynamic 
preview as you do these steps.
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Create a second block, similar to the one shown here. Place the first point of this block at the bottom edge Midpoint (‘MID’) of the first block. For the 
third and final point, let the cursor snap to the right top rear corner of the first block, as shown.

Let’s center the top block. Select Generic Move         then select the top block. Making sure ‘Cursor’ is selected in the Conversation Bar at top left of 
screen, select the Midpoint of the bottom front edge of the top block. Drag the block and allow it to snap to the bottom front edge midpoint of the 
bottom block. 
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Select Modify >Dimension Driven Edit. Create some drafting dimensions by selecting the edges as shown. 

Your model should look similar to the one below after adding the 
dimensions.

Staying in DDE mode, reselect the dimensions to resize the model to the 
dimensions shown below. If needed, re-center the top block. 

Select ‘Delete Multiple’ icon         along top and delete all dimensions.



9

Select Create >Solid Feature >Blend >Constant Blend Place 12mm blends on the four base corners, and 25mm blends on the top 
block’s two corners. The top edge will disappear.

Select Modify >Boolean >Unite Select both blocks. Hit Accept. The two blocks are now one solid.

HINT: Hit ‘Backup’ in Conversation 
Bar to change blend size while 
staying in function.
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Drag and drop the 50% transparency orb 
to the model with the LMB.

Hit Ctrl+1 to change the CPlane to Top.

Change the color by selecting the arrow by this icon         up top, 
which affects all new geometry.

For the third point, hover the cursor over the top of the cylinder until you 
see the ‘MID’ tooltip.

Select the Splitter Window icon        at the top, then select the 
Materials Tab along the bottom of the Splitter Window.

The model should now appear like this.

Sketch a Primitive Block, placing the first corner at the edge 
midpoint as shown. Hold down the Shift key while placing the 
second corner as shown. You should see a ‘NEAR’ tooltip.



11

Using DDE        , make the block 15mm thick.
And 65mm FROM THE TOP of the cylinder.

Using Generic Move         , snap the midpoint of the new block to the 
midpoint of the edge it’s touching, as shown. 

Delete the dimensions using       .

Your model should look like this.

HINT: Only highlight the bottom face of the block when editing the 
dimension.

Your model should look like this.
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We will now create a pattern using the new block. 

Select Create >Solid Feature >Patterns > Linear

Select the block, and Accept. 
To indicate the first direction, select the edge as shown and select 
Accept.

Specify options as shown.

You must reselect the block and Accept in between direction 1 and 2.

Select the second direction, select the edge as shown and select Accept.

Your model should look like this.
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Select the base part as the solid to subtract from.We will now use these blocks to cut through the model.

Select Modify >Boolean >Subtract

The model should look like this.Then select the three blocks and Accept. 
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Create some Constant Blends on the edges as shown. 3mm for between the tabs, 5mm for the two long edges. You can select the edges through the 
model without rotating it.

Select the        icon at top of screen, then select

Specify zero transparency for the entire body and hit OK.

Select model then Accept.

Edges for 5 MM Edges for 3 MM Finished blends
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Select solid to add holes. Make sure you’re still on CPlane 1 (TOP).We will now place some Counterbored holes on the model.

Select Tools >Feature >Counterbored Hole

Specify size M6, and options as shown. If 
you see English and not Metric, select Setup 
tab and change it.

You should see a preview of the cbore hole. Allow the cursor to snap 
to the ‘CENTER’ of each base corner radius. Place the four holes.
Remember you can select edges through model.

Your model should look like the one below now.

NOTE: If you receive this message 
while trying to select an edge through 
the model, it means you’ve selected an 
incorrect edge that likely looks similar 
to the one you’re trying to select. Try to 
select again or simply rotate the model.
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Your model should look like the one below now.

We will now edit a hole using parameters from an existing hole.
Select Modify >Solid Feature >Hole

Change to CPlane 2 (FRONT).
Place another M6 cbore through hole through the front top tab face. 
Again, allow the cursor to snap to the ‘CENTER’ of the cylinder face.

Select the hole on the rear tab, as shown, and Accept.
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Select the Actions tab, and select Get parameters from another hole. Select one of the four base cbores. Hit OK.

Select the face of the rear tab to indicate on which face to put the 
cbore. Accept.

Your model should look like the one below now.
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Select Intersect solid with a plane.

We will now imprint a line onto the model to create new edges that 
separate existing faces. This allows geometry to easily separate from 
the model.
Select Modify >Topology >Imprint

Select a face at the base of the tabs, as shown.
Use spacebar to toggle through selection options if needed.

Your model should now look like this.

Top View

Select the solid for imprint.
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We will now perform some ‘cut & paste’ type functions, using 
geometry on the model.
Select Modify >Boolean >Prune

Select ‘Cut’, ‘Feature’, and ‘Boss’. The geometry we are cutting 
satisfies the ‘boss’ characteristics.

Select Transform >Dynamic to move the separate solids around. Hit ESC          
when done. If you hit Accept select undo before going to the next step.

Select the front and rear tabs.
Hit Accept 3x to complete operation.
These bosses are now separate solids.
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Select the target face as shown.Select Modify >Boolean >Graft

Select the midpoint as shown for boss base position.Select the opposing face (bottom face of boss) as shown.
Use spacebar to toggle through selections if needed.

Make selections as shown.
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The red and green arrows move only along their indicated axis. A 3D Handle will appear at the midpoint.
Click & drag the arrows to manipulate the boss. 

The yellow sphere moves the entire part anywhere it is dragged. The blue arrow rotates. 
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Click & drag the yellow sphere to move the boss to the position 
indicated below and hit Accept.
To temporarily turn off position snapping, hold Ctrl while 
dragging the part.

Select the Delete Multiple icon

Now the newly-placed tab is unified again with the base as one solid.

Hover the cursor over the new tab and use spacebar to toggle until only 
the tab is highlighted. Select and hit Accept. This deletes the extra copy of 
the geometry that grafting leaves behind.
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We will now move the other boss, using Dynamic Transform.
Select Transform >Dynamic
Rotate the model for better viewing of the boss.
Select the remaining boss and Accept.

Select the midpoint as shown for the base point.

The 3D DynaHandle appears at the midpoint. This handle 
behaves similarly to the Graft 3D handle, except all three axes 
can rotate independently.

Select the Red rotation arrow with the Left Mouse Button and hold it down 
and drag until the X Ang=90.

Move the boss to the indicated position. Allow it to snap to the 
edge midpoint.

HINT: The angle will rotate at 5 degree increments by default.
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Right-click the Green rotation arrow as shown.
Select the first option ‘Indicate Y Angle’. 
Enter 90, Accept, then Esc. in the conversation bar.

This is now one solid as shown below.We must unite the two solids.
Select Modify >Boolean >Unite
Select the large green solid and the boss, and Accept.

Model should now look like the one below after moving the boss.
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Hover the cursor over the model and select the Pocket as shown.
Tooltips should appear saying how many faces compose each pocket.

After the three pockets are removed, your model should look like this.

We will now use the Remove Feature function to simplify the model 
geometry.
Select Modify >Solid Face >Remove
Select ‘Feature’ to specify the type of faces to be removed, then 
select ‘Pocket’.

NOTE: A ‘Pocket’ is characterized by a 
group of faces that form a cavity in the 
model.

Hover the cursor over the model and select the Pockets as shown. 
Accept 3x.
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Your model should now look like this.

Select the remaining holes as shown. Hit Accept 3x.We will use Prune to remove the remaining holes.
Select Modify >Boolean >Prune
Select ‘Cut’, ‘Feature’, and ‘Bump’.

Staying in the Feature Removal function, reselect ‘Feature’ 
then select ‘Bump’.

Hover the cursor over the model and select the four cbore 
hole ‘Bumps’. Accept 3x.

NOTE: A ‘Bump’ is characterized by a 
group of faces that compose either a 
cavity or a protrusion on the model.
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The Prune function fills in the holes, leaving behind the hole 
geometry. This geometry can be moved, deleted, hidden etc.

Use Generic Move to move the model away from these hole geometries.

You can either use        to delete this geometry,

or select the ‘Blank Entities’ icon         to temporarily hide it. 

Once you select the Blank Entities icon, select ‘Blank’. Now 
select the hole geometries and Accept.

To unhide a previously-blanked entity, select the ‘Unblank Entities’

icon       . All blanked/hidden entities will appear in black.
Select which entities you wish to unhide and Accept.
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Make sure you highlight only the face shown. Edit both tabs. Delete dims 
afterward.

We will now turn this model into a sheet metal part. Some edits 
must be made first.

Use DDE to select the tab edges shown. Change distance to 25.

The tab should now look like the one below. Do the same for the tab on the other.
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Select Modify >Solid Face >Remove

Select ‘Feature’, ‘Pattern’, and ‘Faces’.

Select one of the base 12mm blends. All others should highlight. Hit 
Accept 3x.

The solid should now look like the one below. Create 3mm blends         on the two edges, as shown.
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Select Modify >Topology >Unstitch

Select options as shown.

Select ‘Feature’, ‘Smooth’, then hover mouse over model until you see this 
selection of one continuous smooth group of faces. Accept 3x.

Solid should now look like the one below.
Delete         the solid below.



31

The solid should now look like the one below.Select Modify >Solid Face >Thicken Sheet
Specify 2mm for thickness.
Select the top sheet just created, then the downward arrow.

Change the color up top for new geometry.
Make sure you’re in CP=2.
Sketch a primitive block as shown.
Hold Shift key while placing 2nd corner.

Select the 3rd point as shown.
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Use DDE to make the block width 3mm. Only highlight the right side of 
block to keep the left side stationary with the dim change.

Model should now look like the one below.

Select the CPlane           icon.

Select the face shown below to position CPlane.

Select Transform >Mirror >Copy
Select the new block and Accept.
Select ‘1 Position Vertical’.
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You should see this.Select the indicated midpoint, then Accept.

Select Modify >Boolean >Subtract

Select the hinge, then box-select the entire model to select the 
two blocks to subtract. Accept.

You should now see this.
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Highlight and select the bottom tab face. 
Use ‘ADD’ to include all tab faces as shown. 

Use DDE to place the following dimensions. 

Change to 30mm. Do the same thing to both tabs.

The model should look like the one below.
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You should now see this. Apply to other side of model.Select the tab to bend, as shown.

Select Modify >Solid Feature >Sheetmetal Bend

Select options in dialogue box as shown.

Select the blend as shown. 

It should now look like this:
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Your model should now look like the one to the left.

Select the face to unfold from, as shown. You should now see this. You may need to unfold a few times in segments. 
Simply keep selecting a top face.

Select Modify >Solid Feature >Unbend All
Select options as shown.
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Please watch for future updates on our website as we continue to add 
more functions and subjects for you to try.

More KeyCreator Training:

Kubotek University

Training

www.kubotek3d.com

https://store.kubotek3d.com/university.aspx
https://www.kubotek3d.com/education/training
http://www.kubotek3d.com
https://twitter.com/Kubotek3d
https://www.kubotek3d.com/blog
http://www.youtube.com/user/KuboTuber1
http://www.facebook.com/KeyCreator

